Hurricane MTA Server 4.0 Upgrade Guide

HURRICANE MTA SERVER 4.0 UPGRADE GUIDE

REQUIREMENTS

Version 4.0 License Key
Windows 2008, 2012, 2016, or 2019
Microsoft .Net Framework 4.8
2 GB RAM minimum, preferably 4-8 GB
2.0 Ghz or faster dual core processor minimum (increased performance
from additional cores or processors)
10-15k RPM hard disk drive, preferably a dedicated drive or RAID array
for Hurricane MTA Server's exclusive use

UPGRADE PROCESS

To upgrade to Hurricane MTA Server 4.0, simply download the 4.0 setup.exe file from our website at http://download.socketlabs.com/hms/4/setup.exe. It is important that you save the file to your local computer and then execute it from there.  

If you have a previous version of Hurricane MTA Server on your system, the setup application will install version 4.0 over top of it, and preserve all of your settings.  We strongly recommend that you backup your existing installation prior to the upgrade.  It is not possible to do a side-by-side installation of 1.x, 2.x, 3.x and or 4.x.

If you are upgrading from a version of Hurricane MTA Server prior to 1.0.0.846 on a 64 bit system, please see the following article: 32 to 64 Bit Upgrade

REVERTING BACK TO A PREVIOUS VERSION

The version 4.x setup performs a one way upgrade of its embedded database system.  So if you wish to revert back to 3.x you will need to restore the /data/master.fdb file from backup.  Once the database file is restored you can re-download the 3.x setup.exe file from our website http://download.socketlabs.com/hms/3/setup.exe and execute it locally.  This will install the latest version of 3.x to your system, and will preserve your settings.  Keep in mind that the latest version of 3.x may be more recent than the version of 3.x you were using prior to your 4.x upgrade.  If you need to restore to the exact same version you were running prior to your 4.x upgrade, you will need to restore from a backup of the Hurricane MTA Server directory prior to the upgrade but beware that your backup of the Hurricane MTA Server directory will contain the entire Hurricane MTA Server state at the time of the backup, including settings, messages in queue, etc...

UPGRADING TO NEWER BUILDS OF 4.X

Once you have 4.0 or higher installed, you can simply update to the latest version of 4.x in one of two ways.  1) use the “Update or Uninstall” shortcut on the Hurricane MTA Server start menu program group, or 2) re-download the setup file from our website http://download.socketlabs.com/hms/4/setup.exe and execute it locally.